]> vaikene.ee Git - evaf/blobdiff - src/plugins/Test/CMakeLists.txt
Ported to Qt5
[evaf] / src / plugins / Test / CMakeLists.txt
index bbf03ba17fb1bc698fe00e6d82d2f2a10a92e750..f4aa339b5969f2a410a33ad71334265d20100039 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET Test)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Include files
 include_directories(${eVaf_INCLUDE})
 
@@ -27,10 +24,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)