]> vaikene.ee Git - evaf/blobdiff - src/plugins/SdiWindow/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / plugins / SdiWindow / CMakeLists.txt
index cd0a8c01829a59f639edbb3c4c398177bacb4c39..9d20998b90b3617fb29fd60739ba8e93dcc47774 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET SdiWindow)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Needed for exporting/importing symbols
 add_definitions(-DSDIWINDOW_LIBRARY)
 
@@ -16,7 +13,12 @@ set(eVaf_LIBRARIES CommonLib PluginsLib GuiLib)
 # Source files
 set(SRCS
     factory.cpp
+    factory.h
+    isdiwindow.h
+    libsdiwindow.h
     sdiwindow.cpp
+    sdiwindow.h
+    version.h
 )
 
 # Header files for the meta-object compiler
@@ -30,10 +32,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets Xml)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)