]> vaikene.ee Git - evaf/blobdiff - src/plugins/SdiWindow/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / plugins / SdiWindow / CMakeLists.txt
index 9edf476798b7378e53b809f735835968e18d263f..9d20998b90b3617fb29fd60739ba8e93dcc47774 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET SdiWindow)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Needed for exporting/importing symbols
 add_definitions(-DSDIWINDOW_LIBRARY)
 
@@ -11,30 +8,36 @@ add_definitions(-DSDIWINDOW_LIBRARY)
 include_directories(${eVaf_INCLUDE})
 
 # Required eVaf libraries
-set(eVaf_LIBRARIES CommonLib PluginsLib)
+set(eVaf_LIBRARIES CommonLib PluginsLib GuiLib)
 
 # Source files
 set(SRCS
     factory.cpp
+    factory.h
+    isdiwindow.h
+    libsdiwindow.h
     sdiwindow.cpp
+    sdiwindow.h
+    version.h
 )
 
 # Header files for the meta-object compiler
 set(MOC_HDRS
     factory.h
-    isdiwindow.h
     sdiwindow.h
 )
 
 # Version info resource file for Windows builds
-if(WIN32)
+if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
-endif(WIN32)
+endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets Xml)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)