]> vaikene.ee Git - evaf/blobdiff - src/plugins/SdiWindow/CMakeLists.txt
Ported to Qt5
[evaf] / src / plugins / SdiWindow / CMakeLists.txt
index cd0a8c01829a59f639edbb3c4c398177bacb4c39..75f9ce79085cf78b8a3b3f467594db1c5cc81dd2 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET SdiWindow)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Needed for exporting/importing symbols
 add_definitions(-DSDIWINDOW_LIBRARY)
 
@@ -30,10 +27,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets Xml)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)