]> vaikene.ee Git - evaf/blobdiff - src/plugins/LogView/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / plugins / LogView / CMakeLists.txt
index ac0d07f98fdf19a7bb111ae4047912b83b25f83e..37700d7af9c3fa7ebfe78e6668695d0b56de37cd 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET LogView)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Needed for exporting/importing symbols
 add_definitions(-DLOGVIEW_LIBRARY)
 
@@ -16,7 +13,11 @@ set(eVaf_LIBRARIES CommonLib PluginsLib GuiLib)
 # Source files
 set(SRCS
     factory.cpp
+    factory.h
+    liblogview.h
     logview.cpp
+    logview.h
+    version.h
 )
 
 # Header files for the meta-object compiler
@@ -30,10 +31,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)