]> vaikene.ee Git - evaf/blobdiff - src/plugins/LogView/CMakeLists.txt
Ported to Qt5
[evaf] / src / plugins / LogView / CMakeLists.txt
index ac0d07f98fdf19a7bb111ae4047912b83b25f83e..1d4b839c0483dcdbff12f7f49be62682efa4f509 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET LogView)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Needed for exporting/importing symbols
 add_definitions(-DLOGVIEW_LIBRARY)
 
@@ -30,10 +27,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)