]> vaikene.ee Git - evaf/blobdiff - src/libs/Common/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / libs / Common / CMakeLists.txt
index 085749e6fc61155ff96d440a52ef00a6356a103b..c5083a39a4406268b96ae2fccad634fa54438a3c 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET CommonLib)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Needed for exporting/importing symbols
 add_definitions(-DCOMMON_LIBRARY)
 
@@ -15,39 +12,64 @@ set(eVaf_LIBRARIES)
 
 # Source files
 set(SRCS
-    app.cpp
-    env.cpp
-    event.cpp
+    app.h
+    config.cpp
+    config.h
     eventqueue.cpp
+    eventqueue.h
     globals.cpp
+    globals.h
+    iapp.h
+    iconfig.h
+    ieventqueue.h
+    ilogger.h
+    inifile.h
+    iprop.h
+    iregistry.h
+    libcommon.h
+    logger.h
+    prop.cpp
+    prop.h
+    app.cpp
+    event.h
+    event.cpp
+    inifile_p.h
+    inifile.cpp
     logger.cpp
     registry.cpp
+    registry.h
     util.cpp
+    util.h
+    version.h
 )
 
 # Header files for the meta-object compiler
 set(MOC_HDRS
     iapp.h
-    ienv.h
     ieventqueue.h
     ilogger.h
     iregistry.h
+    iconfig.h
+    iprop.h
     app.h
-    env.h
     eventqueue.h
     logger.h
     registry.h
+    config.h
+    prop.h
 )
 
 # Version info resource file for Windows builds
-if(WIN32)
+if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
-endif(WIN32)
+endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)