]> vaikene.ee Git - evaf/blobdiff - src/apps/ScosTime/CMakeLists.txt
Added a small utility that converts date/time values
[evaf] / src / apps / ScosTime / CMakeLists.txt
diff --git a/src/apps/ScosTime/CMakeLists.txt b/src/apps/ScosTime/CMakeLists.txt
new file mode 100644 (file)
index 0000000..c56fb72
--- /dev/null
@@ -0,0 +1,41 @@
+# Name of the target
+set(TARGET ScosTime)
+
+# Qt modules
+include(${QT_USE_FILE})
+
+# Include files
+include_directories(${eVaf_INCLUDE})
+
+# Required eVaf libraries
+set(eVaf_LIBRARIES CommonLib PluginsLib GuiLib)
+
+# Source files
+set(SRCS
+    gui.cpp
+)
+
+# Header files for the meta-object compiler
+set(MOC_HDRS
+    gui.h
+)
+
+# Resources
+#set(RCCS
+#    gui.qrc
+#)
+
+# Version info resource file for Windows builds
+if(WIN32 AND NOT MINGW)
+    set(SRCS ${SRCS} version.rc)
+endif(WIN32 AND NOT MINGW)
+
+qt4_add_resources(RCC_SRCS ${RCCS})
+
+qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+
+add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS} ${RCC_SRCS})
+
+target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+
+install(TARGETS ${TARGET} DESTINATION bin)