]> vaikene.ee Git - evaf/blobdiff - src/apps/PswGen/Storage/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / apps / PswGen / Storage / CMakeLists.txt
index 2169469e2613cc63b7baf1a8d37a720a62b549c0..8387080ad4b01d58f45626c8d7c8aca2d1816737 100644 (file)
@@ -1,11 +1,6 @@
 # Name of the target
 set(TARGET PswStorage)
 
-# Qt modules
-set(QT_USE_QTSQL TRUE)
-set(QT_DONT_USE_QTGUI TRUE)
-include(${QT_USE_FILE})
-
 # Needed for exporting symbols
 add_definitions(-DPSWGEN_STORAGE_LIBRARY)
 
@@ -17,7 +12,11 @@ set(eVaf_LIBRARIES CommonLib PluginsLib)
 
 # Source files
 set(SRCS
+    istorage.h
+    lib.h
     module.cpp
+    module.h
+    version.h
 )
 
 # Header files for the meta-object compiler
@@ -30,10 +29,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Sql)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)