]> vaikene.ee Git - evaf/blobdiff - src/apps/PswGen/Generator/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / apps / PswGen / Generator / CMakeLists.txt
index 9325fe95dba1965003a34a7d5b9e644fc018b284..4224491e27f5bf4ba895f1c3b16fe54bd0d494ad 100644 (file)
@@ -1,10 +1,6 @@
 # Name of the target
 set(TARGET PswGen)
 
-# Qt modules
-set(QT_DONT_USE_QTGUI TRUE)
-include(${QT_USE_FILE})
-
 # Needed for exporting/importing symbols
 add_definitions(-DPSWGEN_GENERATOR_LIBRARY)
 
@@ -16,7 +12,11 @@ set(eVaf_LIBRARIES CommonLib PluginsLib)
 
 # Source files
 set(SRCS
+    igenerator.h
+    lib.h
     module.cpp
+    module.h
+    version.h
 )
 
 # Header files for the meta-object compiler
@@ -25,14 +25,16 @@ set(MOC_HDRS
 )
 
 # Version info resource file for Windows builds
-if(WIN32)
+if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
-endif(WIN32)
+endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)