]> vaikene.ee Git - evaf/blobdiff - src/apps/PswGen/GUI/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / apps / PswGen / GUI / CMakeLists.txt
index 561060ec6898ac85241e031cd804784a53c9e892..a582bd257b171381edfb163fc7285d9a89d767d0 100644 (file)
@@ -1,9 +1,6 @@
 # Name of the target
 set(TARGET PswGui)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Include files
 include_directories(${eVaf_INCLUDE})
 
@@ -13,6 +10,9 @@ set(eVaf_LIBRARIES CommonLib PluginsLib GuiLib)
 # Source files
 set(SRCS
     gui.cpp
+    gui.h
+    lib.h
+    version.h
 )
 
 # Header files for the meta-object compiler
@@ -25,10 +25,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)