]> vaikene.ee Git - evaf/blobdiff - src/apps/PswGen/GUI/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / apps / PswGen / GUI / CMakeLists.txt
index 329cd170bbfa949ebf1d2b0149aa52a8fca531e9..a582bd257b171381edfb163fc7285d9a89d767d0 100644 (file)
@@ -1,18 +1,18 @@
 # Name of the target
 set(TARGET PswGui)
 
-# Qt modules
-include(${QT_USE_FILE})
-
 # Include files
 include_directories(${eVaf_INCLUDE})
 
 # Required eVaf libraries
-set(eVaf_LIBRARIES CommonLib PluginsLib)
+set(eVaf_LIBRARIES CommonLib PluginsLib GuiLib)
 
 # Source files
 set(SRCS
     gui.cpp
+    gui.h
+    lib.h
+    version.h
 )
 
 # Header files for the meta-object compiler
@@ -21,14 +21,16 @@ set(MOC_HDRS
 )
 
 # Version info resource file for Windows builds
-if(WIN32)
+if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
-endif(WIN32)
+endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core Widgets)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)