]> vaikene.ee Git - evaf/blobdiff - src/apps/PswGen/CMakeLists.txt
Changes to the build system to enable building without QtGUI.
[evaf] / src / apps / PswGen / CMakeLists.txt
index 01770c2e4c6f021d7602cddc0a904fe6265d6fad..3eadf22269486732b3c9eae9d7aad342a5298cc6 100644 (file)
@@ -1,6 +1,8 @@
 set(eVaf_INCLUDE ${eVaf_INCLUDE} ${CMAKE_SOURCE_DIR}/src/apps/PswGen)
 
-add_subdirectory(GUI)
+if(QT_QTGUI_FOUND)
+  add_subdirectory(GUI)
+endif(QT_QTGUI_FOUND)
 add_subdirectory(CLI)
 add_subdirectory(Generator)
 add_subdirectory(Storage)