]> vaikene.ee Git - evaf/blobdiff - src/apps/PswGen/CLI/CMakeLists.txt
Warning fixes and copyright update.
[evaf] / src / apps / PswGen / CLI / CMakeLists.txt
index ef8ee227b25460bc7df9638cce94fb5f0f8aaf1e..8140b4c43c34bd23966a62260a48f279ff921337 100644 (file)
@@ -1,10 +1,6 @@
 # Name of the target
 set(TARGET PswCli)
 
-# Qt modules
-set(QT_DONT_USE_QTGUI TRUE)
-include(${QT_USE_FILE})
-
 # Include files
 include_directories(${eVaf_INCLUDE})
 
@@ -14,6 +10,9 @@ set(eVaf_LIBRARIES CommonLib PluginsLib)
 # Source files
 set(SRCS
     cli.cpp
+    cli.h
+    lib.h
+    version.h
 )
 
 # Header files for the meta-object compiler
@@ -26,10 +25,12 @@ if(WIN32 AND NOT MINGW)
     set(SRCS ${SRCS} version.rc)
 endif(WIN32 AND NOT MINGW)
 
-qt4_wrap_cpp(MOC_SRCS ${MOC_HDRS})
+qt5_wrap_cpp(MOC_SRCS ${MOC_HDRS})
 
 add_library(${TARGET} SHARED ${SRCS} ${MOC_SRCS})
 
-target_link_libraries(${TARGET} ${QT_LIBRARIES} ${eVaf_LIBRARIES})
+qt5_use_modules(${TARGET} Core)
+
+target_link_libraries(${TARGET} ${eVaf_LIBRARIES})
 
 install(TARGETS ${TARGET} DESTINATION bin)